r1534 + use 0.14.9 as our DB version