r4298 remove require(), which is no longer needed here