r2961 - maintenance->trunk sync of changeset:2940
authorDenis Ovsienko <infrastation@yandex.ru>
Mon, 20 Jul 2009 14:44:38 +0000 (14:44 +0000)
committerDenis Ovsienko <infrastation@yandex.ru>
Mon, 20 Jul 2009 14:44:38 +0000 (14:44 +0000)
README
upgrade.php

diff --git a/README b/README
index 459f76abdcfcdb364a10f8efc9f700e1514ffc78..5bfd9361007af2ce8b33ffbc1a7848ce70f8be60 100644 (file)
--- a/README
+++ b/README
@@ -122,6 +122,14 @@ during the upgrade.
 
 *** Upgrading to 0.17.0 ***
 
 
 *** Upgrading to 0.17.0 ***
 
+One can always install RackTables 0.17.0 from scratch. However, upgrading
+an existing installation to 0.17.0 implies a certain upgrade path. If the
+existing database version is less, than 0.16.4, it must first be upgraded
+to version 0.16.4, 0.16.5 or 0.16.6 (at one's choice) using appropriate
+tar.gz distribution. The resulting 0.16.4+ database can be upgraded to
+0.17.0 (or later version) in a normal way (with tar.gz of the desired 0.17.x
+release).
+
 LDAP options have been moved to LDAP_options array. This means, that if you were
 using LDAP authentication for users in version 0.16.x, it will break right after
 upgrade to 0.17.0. To get things working again, adjust existing secret.php file
 LDAP options have been moved to LDAP_options array. This means, that if you were
 using LDAP authentication for users in version 0.16.x, it will break right after
 upgrade to 0.17.0. To get things working again, adjust existing secret.php file
index 8d05dc7f1aaf8574d54dbb6e1a80b410046855b4..39f184d2d5e0cc5224436356d06857a220cb41c8 100644 (file)
@@ -384,7 +384,8 @@ $path = getDBUpgradePath ($dbver, CODE_VERSION);
 if ($path === NULL)
 {
        echo "<tr><th>Upgrade path</th><td><font color=red>not found</font></td></tr>\n";
 if ($path === NULL)
 {
        echo "<tr><th>Upgrade path</th><td><font color=red>not found</font></td></tr>\n";
-       echo "<tr><th>Summary</th><td>Check README for more information.</td></tr>\n";
+       echo "<tr><th>Summary</th><td>Check README for more information. RackTables releases prior to 0.16.4 ";
+       echo "must be upgraded to 0.16.4 first.</td></tr>\n";
 }
 else
 {
 }
 else
 {