use PHPUnit 7.5.7 instead of 8
authorDenis Ovsienko <denis@ovsienko.info>
Thu, 21 Mar 2019 21:58:08 +0000 (21:58 +0000)
committerDenis Ovsienko <denis@ovsienko.info>
Thu, 21 Mar 2019 22:48:50 +0000 (22:48 +0000)
Run all tests on all PHP versions again.

.travis.yml

index e709079..577e22b 100644 (file)
@@ -12,15 +12,18 @@ matrix:
   - php: 7.0
   - php: 7.1
   - php: 7.2
-    env: SKIP_PHPUNIT=yes # PHPUnit 8
+    env: PHPUNIT_BIN=~/bin/phpunit-7.5.7 # PHPUnit 8 by default
   - php: 7.3
-    env: SKIP_PHPUNIT=yes # PHPUnit 8
+    env: PHPUNIT_BIN=~/bin/phpunit-7.5.7 # PHPUnit 8 by default
 
 services:
  - mysql
 
 before_script:
  - ./tests/travis_setup_mysql.sh racktables_unittest racktables travistest
+ - mkdir -p ~/bin
+ - curl -sSfL -o ~/bin/phpunit-7.5.7 https://phar.phpunit.de/phpunit-7.5.7.phar
+ - chmod a+x ~/bin/phpunit-7.5.7
 
 script:
  - ./tests/express_pre.sh