r2821 - pre-release justifications
authorDenis Ovsienko <infrastation@yandex.ru>
Wed, 3 Jun 2009 14:28:35 +0000 (14:28 +0000)
committerDenis Ovsienko <infrastation@yandex.ru>
Wed, 3 Jun 2009 14:28:35 +0000 (14:28 +0000)
inc/config.php
install/init-dictbase.sql
upgrade.php

index a3c4a9635c2ea4c7c611a47abaf850e4f3b17a70..808e937191c638ae7af4a31e4fb82d5ef81c9004 100644 (file)
@@ -11,7 +11,7 @@
 
 
 // Current code version is subject to change with each new release.
-define ('CODE_VERSION', '0.17.0');
+define ('CODE_VERSION', '0.17.1');
 define ('MAX_DICT_KEY', 988);
 
 define ('TAGNAME_REGEXP', '^[[:alnum:]]([\. _~-]?[[:alnum:]])*$');
index 3c2602bfa2ede0d2564f81dd4e46cbeb50b1db46..4e3d75bca504597a720094fd83147445e2265dcd 100644 (file)
@@ -268,6 +268,6 @@ INSERT INTO `Config` (varname, varvalue, vartype, emptyok, is_hidden, descriptio
 ('FILTER_SUGGEST_TAGS','yes','string','no','no','Suggest tags in list filter'),
 ('FILTER_SUGGEST_PREDICATES','yes','string','no','no','Suggest predicates in list filter'),
 ('FILTER_SUGGEST_EXTRA','no','string','no','no','Suggest extra expression in list filter'),
-('DB_VERSION','0.17.0','string','no','yes','Database version.');
+('DB_VERSION','0.17.1','string','no','yes','Database version.');
 
 INSERT INTO `Script` VALUES ('RackCode','allow {$userid_1}');
index 6e8dcb8a654787efdeefb9b3331a0186a4836916..74290aec359ae75ddc4cfd00f40ea93a3679c49d 100644 (file)
@@ -247,9 +247,9 @@ CREATE TABLE `LDAPCache` (
 
                        break;
                case '0.17.1':
+                       $query[] = "ALTER TABLE Dictionary DROP KEY `chap_to_key`";
                        // Token set has changed, so the cache isn't valid any more.
                        $query[] = "UPDATE Script SET script_text = NULL WHERE script_name = 'RackCodeCache'";
-                       $query[] = "ALTER TABLE Dictionary DROP KEY `chap_to_key`;";
                        $query[] = "UPDATE Config SET varvalue = '0.17.1' WHERE varname = 'DB_VERSION'";
                default:
                        showFailure ("executeUpgradeBatch () failed, because batch '${batchid}' isn't defined", __FILE__);