mention the minimum PHP version in release notes
authorDenis Ovsienko <infrastation@yandex.ru>
Thu, 27 Feb 2014 14:12:36 +0000 (18:12 +0400)
committerDenis Ovsienko <infrastation@yandex.ru>
Thu, 27 Feb 2014 14:12:36 +0000 (18:12 +0400)
README
wwwroot/inc/upgrade.php

diff --git a/README b/README
index 46dc5e3..f309088 100644 (file)
--- a/README
+++ b/README
@@ -108,6 +108,11 @@ and initialize the application.
 
 *** Upgrading to 0.20.7 ***
 
+From now on the minimum (oldest) release of PHP that can run RackTables is
+5.2.10. In particular, to continue running RackTables on CentOS 5 it is
+necessary to replace its php* RPM packages with respective php53* packages
+before the upgrade (except the JSON package, which PHP 5.3 provides internally).
+
 Database triggers are used for some data consistency measures.  The database
 user account must have the 'TRIGGER' privilege, which was introduced in
 MySQL 5.1.7.
index 89cc088..ce0f44d 100644 (file)
@@ -193,6 +193,11 @@ ENDOFTEXT
 ,
 
        '0.20.7' => <<<ENDOFTEXT
+From now on the minimum (oldest) release of PHP that can run RackTables is
+5.2.10. In particular, to continue running RackTables on CentOS 5 it is
+necessary to replace its php* RPM packages with respective php53* packages
+before the upgrade (except the JSON package, which PHP 5.3 provides internally).
+
 Database triggers are used for some data consistency measures.  The database
 user account must have the 'TRIGGER' privilege, which was introduced in
 MySQL 5.1.7.